Vulnerability Summary for the Week of March 8, 2021


microsoft — windows Windows App-V Overlay Filter Elevation of Privilege Vulnerability 2021-03-11 not yet calculated CVE-2021-26860
MISC adobe — animate Adobe Animate version 21.0.3 (and earlier) is affected by a Heap-based Buffer Overflow vulnerability. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. 2021-03-12 not yet calculated CVE-2021-21077
MISC adobe — animate Adobe Animate version 21.0.3 (and earlier) is affected by an Out-of-bounds Read vulnerability. An unauthenticated attacker could leverage this vulnerability to disclose sensitive information in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. 2021-03-12 not yet calculated CVE-2021-21074
MISC adobe — animate Adobe Animate version 21.0.3 (and earlier) is affected by an Out-of-bounds Read vulnerability. An unauthenticated attacker could leverage this vulnerability to disclose sensitive information in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. 2021-03-12 not yet calculated CVE-2021-21075
MISC adobe — animate
  Adobe Animate version 21.0.3 (and earlier) is affected by an Out-of-bounds Read vulnerability. An unauthenticated attacker could leverage this vulnerability to disclose sensitive information in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. 2021-03-12 not yet calculated CVE-2021-21076
MISC adobe — animate
  Adobe Animate version 21.0.3 (and earlier) is affected by a Memory Corruption vulnerability. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. 2021-03-12 not yet calculated CVE-2021-21071
MISC adobe — animate
  Adobe Animate version 21.0.3 (and earlier) is affected by an Out-of-bounds Read vulnerability. An unauthenticated attacker could leverage this vulnerability to disclose sensitive information in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. 2021-03-12 not yet calculated CVE-2021-21072
MISC adobe — animate
  Adobe Animate version 21.0.3 (and earlier) is affected by an Out-of-bounds Read vulnerability. An unauthenticated attacker could leverage this vulnerability to disclose sensitive information in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. 2021-03-12 not yet calculated CVE-2021-21073
MISC adobe — connect
  Adobe Connect version 11.0.7 (and earlier) is affected by an Input Validation vulnerability in the export feature. An attacker could exploit this vulnerability by injecting a payload into the registration form and achieve arbitrary code execution in the context of the admin account. 2021-03-12 not yet calculated CVE-2021-21085
MISC adobe — connect
  Adobe Connect version 11.0.7 (and earlier) is affected by a reflected Cross-Site Scripting (XSS) vulnerability. An attacker could exploit this vulnerability to inject malicious JavaScript content that may be executed within the context of the victim’s browser when they browse to the page containing the vulnerable field. 2021-03-12 not yet calculated CVE-2021-21080
MISC adobe — connect
  Adobe Connect version 11.0.7 (and earlier) is affected by a reflected Cross-Site Scripting (XSS) vulnerability. An attacker could exploit this vulnerability to inject malicious JavaScript content that may be executed within the context of the victim’s browser when they browse to the page containing the vulnerable field. 2021-03-12 not yet calculated CVE-2021-21079
MISC adobe — creative_cloud_desktop_application Adobe Creative Cloud Desktop Application version 5.3 (and earlier) is affected by a local privilege escalation vulnerability that could allow an attacker to call functions against the installer to perform high privileged actions. Exploitation of this issue does not require user interaction. 2021-03-12 not yet calculated CVE-2021-21069
MISC adobe — creative_cloud_desktop_application
  Adobe Creative Cloud Desktop Application version 5.3 (and earlier) is affected by a file handling vulnerability that could allow an attacker to cause arbitrary file overwriting. Exploitation of this issue requires physical access and user interaction. 2021-03-12 not yet calculated CVE-2021-21068
MISC adobe — creative_cloud_desktop_application
  Adobe Creative Cloud Desktop Application version 5.3 (and earlier) is affected by an Unquoted Service Path vulnerability in CCXProcess that could allow an attacker to achieve arbitrary code execution in the process of the current user. Exploitation of this issue requires user interaction 2021-03-12 not yet calculated CVE-2021-21078
MISC adobe — framemaker
  Adobe Framemaker version 2020.0.1 (and earlier) is affected by an Out-of-bounds Read vulnerability when parsing a specially crafted file. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. 2021-03-12 not yet calculated CVE-2021-21056
MISC adobe — photoshop
  Adobe Photoshop versions 21.2.5 (and earlier) and 22.2 (and earlier) are affected by a Memory Corruption vulnerability when parsing a specially crafted file. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. 2021-03-12 not yet calculated CVE-2021-21082
MISC adobe — photoshop
  Adobe Photoshop versions 21.2.5 (and earlier) and 22.2 (and earlier) are affected by an Out-of-bounds Write vulnerability in the CoolType library. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. 2021-03-12 not yet calculated CVE-2021-21067
MISC ansible-tower — ansible-tower
  A flaw was found in ansible-tower. The default installation is vulnerable to Job Isolation escape allowing an attacker to elevate the privilege from a low privileged user to the awx user from outside the isolated environment. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. 2021-03-09 not yet calculated CVE-2021-20253
MISC apache — velocity
  An attacker that is able to modify Velocity templates may execute arbitrary Java code or run arbitrary system commands with the same privileges as the account running the Servlet container. This applies to applications that allow untrusted users to upload/modify velocity templates running Apache Velocity Engine versions up to 2.2. 2021-03-10 not yet calculated CVE-2020-13936
MLIST
CONFIRM
MLIST
MLIST
MLIST apache — velocity_tools
  The default error page for VelocityView in Apache Velocity Tools prior to 3.1 reflects back the vm file that was entered as part of the URL. An attacker can set an XSS payload file as this vm file in the URL which results in this payload being executed. XSS vulnerabilities allow attackers to execute arbitrary JavaScript in the context of the attacked website and the attacked user. This can be abused to steal session cookies, perform requests in the name of the victim or for phishing attacks. 2021-03-10 not yet calculated CVE-2020-13959
MLIST
CONFIRM
MLIST
MLIST
MLIST athom — homey_and_homey_pro_devices
  An issue was discovered on Athom Homey and Homey Pro devices before 5.0.0. ZigBee hub devices should generate a unique Standard Network Key that is then exchanged with all enrolled devices so that all inter-device communication is encrypted. However, the cited Athom products use another widely known key that is designed for testing purposes: “01030507090b0d0f00020406080a0c0d” (the decimal equivalent of 1 3 5 7 9 11 13 15 0 2 4 6 8 10 12 13), which is human generated and static across all issued devices. 2021-03-09 not yet calculated CVE-2020-28952
MISC
MISC
MISC baby_care_system — baby_care_system
  Baby Care System 1.0 is affected by a cross-site scripting (XSS) vulnerability in the Edit Page tab through the Post title parameter. 2021-03-10 not yet calculated CVE-2020-35752
MISC
MISC
MISC bloomreach — experience_manager
  An issue was discovered in Bloomreach Experience Manager (brXM) 4.1.0 through 14.2.2. It allows remote attackers to execute arbitrary code because there is a mishandling of the capability for administrators to write and run Groovy scripts within the updater editor. An attacker must use an AST transforming annotation such as @Grab. 2021-03-11 not yet calculated CVE-2020-14987
MISC bloomreach — experience_manager
  An issue was discovered in Bloomreach Experience Manager (brXM) 4.1.0 through 14.2.2. It allows XSS in the login page via the loginmessage parameter, the text editor via the src attribute of HTML elements, the translations menu via the foldername parameter, the author page via the link URL, or the upload image functionality via an SVG document containing JavaScript. 2021-03-11 not yet calculated CVE-2020-14988
MISC bloomreach — experience_manager
  An issue was discovered in Bloomreach Experience Manager (brXM) 4.1.0 through 14.2.2. It allows CSRF if the attacker uses GET where POST was intended. 2021-03-11 not yet calculated CVE-2020-14989
MISC camunda — modeler
  ** DISPUTED ** Camunda Modeler (aka camunda-modeler) through 4.6.0 allows arbitrary file access. A remote attacker may send a crafted IPC message to the exposed vulnerable ipcRenderer IPC interface, which manipulates the readFile and writeFile APIs. NOTE: the vendor states “The way we secured the app is that it does not allow any remote scripts to be opened, no unsafe scripts to be evaluated, no remote sites to be browsed.” 2021-03-11 not yet calculated CVE-2021-28154
MISC changeset — changeset
  Prototype pollution vulnerability in ‘changeset’ versions 0.0.1 through 0.2.5 allows an attacker to cause a denial of service and may lead to remote code execution. 2021-03-09 not yet calculated CVE-2021-25915
MISC
MISC clipper — clipper
  Clipper before 1.0.5 allows remote command execution. A remote attacker may send a crafted IPC message to the exposed vulnerable ipcRenderer IPC interface, which invokes the dangerous openExternal API. 2021-03-11 not yet calculated CVE-2021-28134
MISC
MISC
MISC
MISC com.bmuschko — com.bmuschko
  The `com.bmuschko:gradle-vagrant-plugin` Gradle plugin contains an information disclosure vulnerability due to the logging of the system environment variables. When this Gradle plugin is executed in public CI/CD, this can lead to sensitive credentials being exposed to malicious actors. This is fixed in version 3.0.0. 2021-03-09 not yet calculated CVE-2021-21361
MISC
MISC
MISC
CONFIRM containerd — containerd
  In containerd (an industry-standard container runtime) before versions 1.3.10 and 1.4.4, containers launched through containerd’s CRI implementation (through Kubernetes, crictl, or any other pod/container client that uses the containerd CRI service) that share the same image may receive incorrect environment variables, including values that are defined for other containers. If the affected containers have different security contexts, this may allow sensitive information to be unintentionally shared. If you are not using containerd’s CRI implementation (through one of the mechanisms described above), you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image which have different environment variables, you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image in rapid succession, you have reduced likelihood of being vulnerable to this issue This vulnerability has been fixed in containerd 1.3.10 and containerd 1.4.4. Users should update to these versions. 2021-03-10 not yet calculated CVE-2021-21334
MISC
MISC
MISC
CONFIRM
FEDORA
FEDORA cortex — xsoar
  An information exposure through log file vulnerability exists in Cortex XSOAR software where the secrets configured for the SAML single sign-on (SSO) integration can be logged to the ‘/var/log/demisto/’ server logs when testing the integration during setup. This logged information includes the private key and identity provider certificate used to configure the SAML SSO integration. This issue impacts: Cortex XSOAR 5.5.0 builds earlier than 98622; Cortex XSOAR 6.0.1 builds earlier than 830029; Cortex XSOAR 6.0.2 builds earlier than 98623; Cortex XSOAR 6.1.0 builds earlier than 848144. 2021-03-10 not yet calculated CVE-2021-3034
CONFIRM csz — csz
  CSZ CMS 1.2.9 is affected by a cross-site scripting (XSS) vulnerability in multiple pages through the field name. 2021-03-11 not yet calculated CVE-2021-26776
MISC d-link — dir-3060_devices
  prog.cgi on D-Link DIR-3060 devices before 1.11b04 HF2 allows remote authenticated users to inject arbitrary commands in an admin or root context because SetVirtualServerSettings calls CheckArpTables, which calls popen unsafely. 2021-03-11 not yet calculated CVE-2021-28144
MISC
FULLDISC
CONFIRM
MISC d-link– dir-841_devices
  /jsonrpc on D-Link DIR-841 3.03 and 3.04 devices allows authenticated command injection via ping, ping6, or traceroute (under System Tools). 2021-03-11 not yet calculated CVE-2021-28143
MISC
MISC dell — supportassist
  Dell SupportAssist Client for Consumer PCs versions 3.7.x, 3.6.x, 3.4.x, 3.3.x, Dell SupportAssist Client for Business PCs versions 2.0.x, 2.1.x, 2.2.x, and Dell SupportAssist Client ProManage 1.x contain a DLL injection vulnerability in the Costura Fody plugin. A local user with low privileges could potentially exploit this vulnerability, leading to the execution of arbitrary executable on the operating system with SYSTEM privileges. 2021-03-12 not yet calculated CVE-2021-21518
CONFIRM eclipse — platform
  In versions 4.18 and earlier of the Eclipse Platform, the Help Subsystem does not authenticate active help requests to the local help web server, allowing an unauthenticated local attacker to issue active help commands to the associated Eclipse Platform process or Eclipse Rich Client Platform process. 2021-03-09 not yet calculated CVE-2020-27225
CONFIRM eclipse — theia
  In Eclipse Theia versions up to and including 1.8.0, in the debug console there is no HTML escaping, so arbitrary Javascript code can be injected. 2021-03-12 not yet calculated CVE-2021-28161
CONFIRM eclipse — theia
  In Eclipse Theia versions up to and including 0.16.0, in the notification messages there is no HTML escaping, so Javascript code can run. 2021-03-12 not yet calculated CVE-2021-28162
CONFIRM emerson — smart_wireless_gateway
  Incorrect Access Control in Emerson Smart Wireless Gateway 1420 4.6.59 allows remote attackers to obtain sensitive device information from the administrator console without authentication. 2021-03-10 not yet calculated CVE-2020-19419
MISC emerson — smart_wireless_gateway
  Emerson Smart Wireless Gateway 1420 4.6.59 allows non-privileged users (such as the default account ‘maint’) to perform administrative tasks by sending specially crafted HTTP requests to the application. 2021-03-10 not yet calculated CVE-2020-19417
MISC envoy — envoy
  Envoy is a cloud-native high-performance edge/middle/service proxy. In Envoy version 1.17.0 an attacker can bypass authentication by presenting a JWT token with an issuer that is not in the provider list when Envoy’s JWT Authentication filter is configured with the `allow_missing` requirement under `requires_any` due to a mistake in implementation. Envoy’s JWT Authentication filter can be configured with the `allow_missing` requirement that will be satisfied if JWT is missing (JwtMissed error) and fail if JWT is presented or invalid. Due to a mistake in implementation, a JwtUnknownIssuer error was mistakenly converted to JwtMissed when `requires_any` was configured. So if `allow_missing` was configured under `requires_any`, an attacker can bypass authentication by presenting a JWT token with an issuer that is not in the provider list. Integrity may be impacted depending on configuration if the JWT token is used to protect against writes or modifications. This regression was introduced on 2020/11/12 in PR 13839 which fixed handling `allow_missing` under RequiresAny in a JwtRequirement (see issue 13458). The AnyVerifier aggregates the children verifiers’ results into a final status where JwtMissing is the default error. However, a JwtUnknownIssuer was mistakenly treated the same as a JwtMissing error and the resulting final aggregation was the default JwtMissing. As a result, `allow_missing` would allow a JWT token with an unknown issuer status. This is fixed in version 1.17.1 by PR 15194. The fix works by preferring JwtUnknownIssuer over a JwtMissing error, fixing the accidental conversion and bypass with `allow_missing`. A user could detect whether a bypass occurred if they have Envoy logs enabled with debug verbosity. Users can enable component level debug logs for JWT. The JWT filter logs will indicate that there is a request with a JWT token and a failure that the JWT token is missing. 2021-03-11 not yet calculated CVE-2021-21378
MISC
MISC
CONFIRM facebook — gameroom
  The fbgames protocol handler registered as part of Facebook Gameroom does not properly quote arguments passed to the executable. That allows a malicious URL to cause code execution. This issue affects versions prior to v1.26.0. 2021-03-10 not yet calculated CVE-2021-24030
CONFIRM flatpak — flatpak
  Flatpak is a system for building, distributing, and running sandboxed desktop applications on Linux. In Flatpack since version 0.9.4 and before version 1.10.2 has a vulnerability in the “file forwarding” feature which can be used by an attacker to gain access to files that would not ordinarily be allowed by the app’s permissions. By putting the special tokens `@@` and/or `@@u` in the Exec field of a Flatpak app’s .desktop file, a malicious app publisher can trick flatpak into behaving as though the user had chosen to open a target file with their Flatpak app, which automatically makes that file available to the Flatpak app. This is fixed in version 1.10.2. A minimal solution is the first commit “`Disallow @@ and @@U usage in desktop files`”. The follow-up commits “`dir: Reserve the whole @@ prefix`” and “`dir: Refuse to export .desktop files with suspicious uses of @@ tokens`” are recommended, but not strictly required. As a workaround, avoid installing Flatpak apps from untrusted sources, or check the contents of the exported `.desktop` files in `exports/share/applications/*.desktop` (typically `~/.local/share/flatpak/exports/share/applications/*.desktop` and `/var/lib/flatpak/exports/share/applications/*.desktop`) to make sure that literal filenames do not follow `@@` or `@@u`. 2021-03-11 not yet calculated CVE-2021-21381
MISC
MISC
MISC
MISC
MISC
CONFIRM
DEBIAN git — git
  Git is an open-source distributed revision control system. In affected versions of Git a specially crafted repository that contains symbolic links as well as files using a clean/smudge filter such as Git LFS, may cause just-checked out script to be executed while cloning onto a case-insensitive file system such as NTFS, HFS+ or APFS (i.e. the default file systems on Windows and macOS). Note that clean/smudge filters have to be configured for that. Git for Windows configures Git LFS by default, and is therefore vulnerable. The problem has been patched in the versions published on Tuesday, March 9th, 2021. As a workaound, if symbolic link support is disabled in Git (e.g. via `git config –global core.symlinks false`), the described attack won’t work. Likewise, if no clean/smudge filters such as Git LFS are configured globally (i.e. _before_ cloning), the attack is foiled. As always, it is best to avoid cloning repositories from untrusted sources. The earliest impacted version is 2.14.2. The fix versions are: 2.30.1, 2.29.3, 2.28.1, 2.27.1, 2.26.3, 2.25.5, 2.24.4, 2.23.4, 2.22.5, 2.21.4, 2.20.5, 2.19.6, 2.18.5, 2.17.62.17.6. 2021-03-09 not yet calculated CVE-2021-21300
MLIST
MISC
CONFIRM
MISC
MISC
FEDORA
MISC glpi — glpi
  GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 it is possible to create tickets for another user with self-service interface without delegatee systems enabled. This is fixed in version 9.5.4. 2021-03-08 not yet calculated CVE-2021-21326
MISC
CONFIRM glpi — glpi
  GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 there is an Insecure Direct Object Reference (IDOR) on “Solutions”. This vulnerability gives an unauthorized user the ability to enumerate GLPI items names (including users logins) using the knowbase search form (requires authentication). To Reproduce: Perform a valid authentication at your GLPI instance, Browse the ticket list and select any open ticket, click on Solution form, then Search a solution form that will redirect you to the endpoint /”glpi/front/knowbaseitem.php?item_itemtype=Ticket&item_items_id=18&forcetab=Knowbase$1″, and the item_itemtype=Ticket parameter present in the previous URL will point to the PHP alias of glpi_tickets table, so just replace it with “Users” to point to glpi_users table instead; in the same way, item_items_id=18 will point to the related column id, so changing it too you should be able to enumerate all the content which has an alias. Since such id(s) are obviously incremental, a malicious party could exploit the vulnerability simply by guessing-based attempts. 2021-03-08 not yet calculated CVE-2021-21324
MISC
MISC
CONFIRM glpi — glpi
  GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 non-authenticated user can remotely instantiate object of any class existing in the GLPI environment that can be used to carry out malicious attacks, or to start a “POP chain”. As an example of direct impact, this vulnerability affects integrity of the GLPI core platform and third-party plugins runtime misusing classes which implement some sensitive operations in their constructors or destructors. This is fixed in version 9.5.4. 2021-03-08 not yet calculated CVE-2021-21327
MISC
MISC
CONFIRM glpi — glpi
  GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 a new budget type can be defined by user. This input is not correctly filtered. This results in a cross-site scripting attack. To exploit this endpoint attacker need to be authenticated. This is fixed in version 9.5.4. 2021-03-08 not yet calculated CVE-2021-21325
MISC
CONFIRM gnome — glib
  An issue was discovered in GNOME GLib before 2.66.8. When g_file_replace() is used with G_FILE_CREATE_REPLACE_DESTINATION to replace a path that is a dangling symlink, it incorrectly also creates the target of the symlink as an empty file, which could conceivably have security relevance if the symlink is attacker-controlled. (If the path is a symlink to a file that already exists, then the contents of that file correctly remain unchanged.) 2021-03-11 not yet calculated CVE-2021-28153
MISC gnutls — gnutls
  A flaw was found in gnutls. A use after free issue in client_send_params in lib/ext/pre_shared_key.c may lead to memory corruption and other potential consequences. 2021-03-12 not yet calculated CVE-2021-20232
MISC
MISC gnutls — gnutls
  A flaw was found in gnutls. A use after free issue in client sending key_share extension may lead to memory corruption and other consequences. 2021-03-12 not yet calculated CVE-2021-20231
MISC
MISC go — go
  archive/zip in Go 1.16.x before 1.16.1 allows attackers to cause a denial of service (panic) upon attempted use of the Reader.Open API for a ZIP archive in which ../ occurs at the beginning of any filename. 2021-03-11 not yet calculated CVE-2021-27919
MISC go — go
  encoding/xml in Go before 1.15.9 and 1.16.x before 1.16.1 has an infinite loop if a custom TokenReader (for xml.NewTokenDecoder) returns EOF in the middle of an element. This can occur in the Decode, DecodeElement, or Skip method. 2021-03-11 not yet calculated CVE-2021-27918
MISC google — android In DeltaPerformer::Write of delta_performer.cc, there is a possible use of untrusted input due to improper input validation. This could lead to a local bypass of defense in depth protections with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-11Android ID: A-160800689 2021-03-10 not yet calculated CVE-2021-0377
MISC google — android In sound_trigger_event_alloc of platform.h, there is a possible out of bounds write due to a heap buffer overflow. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-167663878 2021-03-10 not yet calculated CVE-2021-0464
MISC google — android In the FingerTipS touch screen driver, there is a possible out of bounds read due to an integer overflow. This could lead to local information disclosure with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-157156744 2021-03-10 not yet calculated CVE-2021-0458
MISC
MISC google — android In qtaguid_untag of xt_qtaguid.c, there is a possible memory corruption due to a use after free. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-176919394References: Upstream kernel 2021-03-10 not yet calculated CVE-2021-0399
MISC google — android In bindServiceLocked of ActiveServices.java, there is a possible foreground service launch due to a confused deputy. This could lead to local escalation of privilege with User execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-11Android ID: A-173516292 2021-03-10 not yet calculated CVE-2021-0398
MISC google — android In Builtins::Generate_ArgumentsAdaptorTrampoline of builtins-arm.cc and related files, there is a possible out of bounds write due to an incorrect bounds check. This could lead to remote code execution in an unprivileged process with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-8.1 Android-9 Android-10 Android-11Android ID: A-160610106 2021-03-10 not yet calculated CVE-2021-0396
MISC google — android In fts_driver_test_write of fts_proc.c, there is a possible out of bounds read due to a missing bounds check. This could lead to local information disclosure with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-157154534 2021-03-10 not yet calculated CVE-2021-0459
MISC
MISC google — android In nci_proc_rf_management_ntf of nci_hrcv.cc, there is a possible out of bounds read due to a missing bounds check. This could lead to local escalation of privilege with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-11Android ID: A-164440989 2021-03-10 not yet calculated CVE-2021-0371
MISC google — android
  In the FingerTipS touch screen driver, there is a possible out of bounds write due to a heap buffer overflow. This could lead to local escalation of privilege with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-157155375 2021-03-10 not yet calculated CVE-2021-0457
MISC
MISC google — android
  In checkUriPermission and related functions of MediaProvider.java, there is a possible way to access external files due to a permissions bypass. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-11Android ID: A-115619667 2021-03-10 not yet calculated CVE-2021-0376
MISC google — android
  In GenerateFaceMask of face.cc, there is a possible out of bounds write due to an incorrect bounds check. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-172005755 2021-03-10 not yet calculated CVE-2021-0465
MISC google — android
  In convertToHidl of convert.cpp, there is a possible out of bounds read due to uninitialized data from ReturnFrameworkMessage. This could lead to local information disclosure with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-154867068 2021-03-10 not yet calculated CVE-2021-0463
MISC google — android
  In the NXP NFC firmware, there is a possible insecure firmware update due to a logic error. This could lead to local escalation of privilege with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-168799695 2021-03-10 not yet calculated CVE-2021-0462
MISC google — android
  In iaxxx_core_sensor_change_state of iaxxx-module.c, there is a possible out of bounds write due to a missing bounds check. This could lead to local escalation of privilege with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-175124074 2021-03-10 not yet calculated CVE-2021-0461
MISC google — android
  In the FingerTipS touch screen driver, there is a possible out of bounds read due to an integer overflow. This could lead to local information disclosure with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-156739245 2021-03-10 not yet calculated CVE-2021-0460
MISC google — android
  In the Citadel chip firmware, there is a possible out of bounds write due to a missing bounds check. This could lead to local escalation of privilege with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-174769927 2021-03-10 not yet calculated CVE-2021-0456
MISC google — android
  In oggpack_look of bitwise.c, there is a possible out of bounds read due to a missing bounds check. This could lead to remote information disclosure with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android-11Android ID: A-169829774 2021-03-10 not yet calculated CVE-2021-0368
MISC google — android
  In sdp_copy_raw_data of sdp_discovery.cc, there is a possible system compromise due to a double free. This could lead to remote code execution with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-11 Android-8.1 Android-9 Android-10Android ID: A-174052148 2021-03-10 not yet calculated CVE-2021-0397
MISC google — android
  In CrossProfileAppsServiceImpl.java, there is the possibility of an application’s INTERACT_ACROSS_PROFILES grant state not displaying properly in the setting UI due to a logic error in the code. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android-11Android ID: A-166561076 2021-03-10 not yet calculated CVE-2021-0369
MISC google — android
  In various methods of WifiNetworkSuggestionsManager.java, there is a possible modification of suggested networks due to a missing permission check. This could lead to local escalation of privilege by a background user on the same device with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-11 Android-8.1 Android-9 Android-10Android ID: A-174749461 2021-03-10 not yet calculated CVE-2021-0390
MISC google — android
  In Write of NxpMfcReader.cc, there is a possible out of bounds write due to a missing bounds check. This could lead to local escalation of privilege in the NFC server with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-11Android ID: A-169259605 2021-03-10 not yet calculated CVE-2021-0370
MISC hhvm — hhvm The unserialize() function supported a type code, “S”, which was meant to be supported only for APC serialization. This type code allowed arbitrary memory addresses to be accessed as if they were static StringData objects. This issue affected HHVM prior to v4.32.3, between versions 4.33.0 and 4.56.0, 4.57.0, 4.58.0, 4.58.1, 4.59.0, 4.60.0, 4.61.0, 4.62.0. 2021-03-11 not yet calculated CVE-2020-1899
MISC
CONFIRM hhvm — hhvm When unserializing an object with dynamic properties HHVM needs to pre-reserve the full size of the dynamic property array before inserting anything into it. Otherwise the array might resize, invalidating previously stored references. This pre-reservation was not occurring in HHVM prior to v4.32.3, between versions 4.33.0 and 4.56.0, 4.57.0, 4.58.0, 4.58.1, 4.59.0, 4.60.0, 4.61.0, 4.62.0. 2021-03-11 not yet calculated CVE-2020-1900
MISC
CONFIRM hhvm — hhvm An incorrect size calculation in ldap_escape may lead to an integer overflow when overly long input is passed in, resulting in an out-of-bounds write. This issue affects HHVM prior to 4.56.2, all versions between 4.57.0 and 4.78.0, 4.79.0, 4.80.0, 4.81.0, 4.82.0, 4.83.0. 2021-03-10 not yet calculated CVE-2020-1916
MISC
CONFIRM hhvm — hhvm xbuf_format_converter, used as part of exif_read_data, was appending a terminating null character to the generated string, but was not using its standard append char function. As a result, if the buffer was full, it would result in an out-of-bounds write. This issue affects HHVM versions prior to 4.56.3, all versions between 4.57.0 and 4.80.1, all versions between 4.81.0 and 4.93.1, and versions 4.94.0, 4.95.0, 4.96.0, 4.97.0, 4.98.0. 2021-03-10 not yet calculated CVE-2020-1917
MISC
MISC hhvm — hhvm In-memory file operations (ie: using fopen on a data URI) did not properly restrict negative seeking, allowing for the reading of memory prior to the in-memory buffer. This issue affects HHVM versions prior to 4.56.3, all versions between 4.57.0 and 4.80.1, all versions between 4.81.0 and 4.93.1, and versions 4.94.0, 4.95.0, 4.96.0, 4.97.0, 4.98.0. 2021-03-10 not yet calculated CVE-2020-1918
MISC
MISC hhvm — hhvm Incorrect bounds calculations in substr_compare could lead to an out-of-bounds read when the second string argument passed in is longer than the first. This issue affects HHVM versions prior to 4.56.3, all versions between 4.57.0 and 4.80.1, all versions between 4.81.0 and 4.93.1, and versions 4.94.0, 4.95.0, 4.96.0, 4.97.0, 4.98.0. 2021-03-10 not yet calculated CVE-2020-1919
MISC
MISC hhvm — hhvm
  Due to incorrect string size calculations inside the preg_quote function, a large input string passed to the function can trigger an integer overflow leading to a heap overflow. This issue affects HHVM versions prior to 4.56.3, all versions between 4.57.0 and 4.80.1, all versions between 4.81.0 and 4.93.1, and versions 4.94.0, 4.95.0, 4.96.0, 4.97.0, 4.98.0. 2021-03-10 not yet calculated CVE-2021-24025
MISC
MISC hhvm — hhvm
  The fb_unserialize function did not impose a depth limit for nested deserialization. That meant a maliciously constructed string could cause deserialization to recurse, leading to stack exhaustion. This issue affected HHVM prior to v4.32.3, between versions 4.33.0 and 4.56.0, 4.57.0, 4.58.0, 4.58.1, 4.59.0, 4.60.0, 4.61.0, 4.62.0. 2021-03-11 not yet calculated CVE-2020-1898
MISC
CONFIRM hhvm — hhvm
  In the crypt function, we attempt to null terminate a buffer using the size of the input salt without validating that the offset is within the buffer. This issue affects HHVM versions prior to 4.56.3, all versions between 4.57.0 and 4.80.1, all versions between 4.81.0 and 4.93.1, and versions 4.94.0, 4.95.0, 4.96.0, 4.97.0, 4.98.0. 2021-03-10 not yet calculated CVE-2020-1921
MISC
MISC hyperledger — besu
  Hyperledger Besu is an open-source, MainNet compatible, Ethereum client written in Java. In Besu before version 1.5.1 there is a denial-of-service vulnerability involving the HTTP JSON-RPC API service. If username and password authentication is enabled for the HTTP JSON-RPC API service, then prior to making any requests to an API endpoint the requestor must use the login endpoint to obtain a JSON web token (JWT) using their credentials. A single user can readily overload the login endpoint with invalid requests (incorrect password). As the supplied password is checked for validity on the main vertx event loop and takes a relatively long time this can cause the processing of other valid requests to fail. A valid username is required for this vulnerability to be exposed. This has been fixed in version 1.5.1. 2021-03-09 not yet calculated CVE-2021-21369
MISC
MISC
MISC
CONFIRM ibm — datapower_gateway IBM DataPower Gateway V10 and V2018 could allow a local attacker with administrative privileges to execute arbitrary code on the system using a server-side requesr forgery attack. IBM X-Force ID: 193247. 2021-03-08 not yet calculated CVE-2020-5014
XF
CONFIRM ibm — datapower_gateway
  IBM DataPower Gateway 10.0.0.0 through 10.0.1.0 uses weaker than expected cryptographic algorithms that could allow an attacker to decrypt highly sensitive information. IBM X-Force ID: 189965. 2021-03-12 not yet calculated CVE-2020-4831
XF
CONFIRM ibm — db2
  IBM DB2 for Linux, UNIX and Windows (includes DB2 Connect Server) 9.7, 10.1, 10.5, 11.1, and 11.5 could allow a local user to read and write specific files due to weak file permissions. IBM X-Force ID: 192469. 2021-03-11 not yet calculated CVE-2020-4976
XF
CONFIRM ibm — db2
  IBM DB2 for Linux, UNIX and Windows (includes DB2 Connect Server) 9.7, 10.1, 10.5, 11.1, and 11.5 could allow an unauthenticated attacker to cause a denial of service due a hang in the SSL handshake response. IBM X-Force ID: 193660. 2021-03-11 not yet calculated CVE-2020-5024
XF
CONFIRM ibm — db2
  IBM DB2 for Linux, UNIX and Windows (includes DB2 Connect Server) 9.7, 10.1, 10.5, 11.1, and 11.5 db2fm is vulnerable to a buffer overflow, caused by improper bounds checking which could allow a local attacker to execute arbitrary code on the system with root privileges. IBM X-Force ID: 193661. 2021-03-11 not yet calculated CVE-2020-5025
XF
CONFIRM ibm — spss_modeler_subscription
  A vulnerability exists in IBM SPSS Modeler Subscription Installer that allows a user with create symbolic link permission to write arbitrary file in another protected path during product installation. IBM X-Force ID: 187727. 2021-03-10 not yet calculated CVE-2020-4717
XF
CONFIRM ibm — tivoli_netcool
  IBM Tivoli Netcool/OMNIbus_GUI 8.1.0 is vulnerable to stored cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. 2021-03-11 not yet calculated CVE-2021-20336
XF
CONFIRM ibm — websphere_application_server
  IBM WebSphere Application Server 7.0, 8.0, 8.5, and 9.0 could allow a remote attacker to traverse directories on the system. When application security is disabled and JAX-RPC applications are present, an attacker could send a specially-crafted URL request containing “dot dot” sequences (/../) to view arbitrary xml files on the system. This does not occur if Application security is enabled. IBM X-Force ID: 193556. 2021-03-10 not yet calculated CVE-2020-5016
XF
CONFIRM imagemagick — imagemagick
  A flaw was found in ImageMagick in coders/webp.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability. 2021-03-09 not yet calculated CVE-2021-20245
MISC
MISC imagemagick — magickcore
  A flaw was found in ImageMagick in MagickCore/visual-effects.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability. 2021-03-09 not yet calculated CVE-2021-20244
MISC
MISC imagemagick — magickcore
  A flaw was found in ImageMagick in MagickCore/resample.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability. 2021-03-09 not yet calculated CVE-2021-20246
MISC is-svg — is-svg
  The is-svg package 2.1.0 through 4.2.1 for Node.js uses a regular expression that is vulnerable to Regular Expression Denial of Service (ReDoS). If an attacker provides a malicious string, is-svg will get stuck processing the input for a very long time. 2021-03-12 not yet calculated CVE-2021-28092
MISC
MISC
MISC jspdf — jspdf
  This affects the package jspdf before 2.3.1. ReDoS is possible via the addImage function. 2021-03-09 not yet calculated CVE-2021-23353
MISC
MISC
MISC
MISC
MISC
MISC
MISC kentico — cms
  The Blog module in Kentico CMS 5.5 R2 build 5.5.3996 allows SQL injection via the tagname parameter. 2021-03-05 not yet calculated CVE-2021-27581
MISC
MISC
MISC lenovo — xclarity_administrator
  An internal product security audit of LXCO, prior to version 1.2.2, discovered that credentials for Lenovo XClarity Administrator (LXCA), if added as a Resource Manager, are encoded then written to an internal LXCO log file each time a session is established with LXCA. Affected logs are captured in the First Failure Data Capture (FFDC) service log. The FFDC service log is only generated when requested by a privileged LXCO user and it is only accessible to the privileged LXCO user that requested the file. 2021-03-09 not yet calculated CVE-2021-3417
MISC leptonica — leptonica Leptonica before 1.80.0 allows a heap-based buffer over-read in pixReadFromTiffStream, related to tiffio.c. 2021-03-12 not yet calculated CVE-2020-36280
MISC
MISC
MISC leptonica — leptonica Leptonica before 1.80.0 allows a heap-based buffer over-read in findNextBorderPixel in ccbord.c. 2021-03-12 not yet calculated CVE-2020-36278
MISC
MISC
MISC leptonica — leptonica Leptonica before 1.80.0 allows a heap-based buffer over-read in pixFewColorsOctcubeQuantMixed in colorquant1.c. 2021-03-12 not yet calculated CVE-2020-36281
MISC
MISC
MISC leptonica — leptonica
  Leptonica before 1.80.0 allows a heap-based buffer over-read in rasteropGeneralLow, related to adaptmap_reg.c and adaptmap.c. 2021-03-12 not yet calculated CVE-2020-36279
MISC
MISC
MISC leptonica — leptonica
  Leptonica before 1.80.0 allows a denial of service (application crash) via an incorrect left shift in pixConvert2To8 in pixconv.c. 2021-03-11 not yet calculated CVE-2020-36277
MISC
MISC
MISC lib3mf — lib3mf
  A use-after-free vulnerability exists in the NMR::COpcPackageReader::releaseZIP() functionality of 3MF Consortium lib3mf 2.0.0. A specially crafted 3MF file can lead to code execution. An attacker can provide a malicious file to trigger this vulnerability. 2021-03-10 not yet calculated CVE-2021-21772
MISC libjpeg-turbo — libjpeg-turbo
  Libjpeg-turbo versions 2.0.91 and 2.0.90 is vulnerable to a denial of service vulnerability caused by a divide by zero when processing a crafted GIF image. 2021-03-10 not yet calculated CVE-2021-20205
MISC libtiff — libtiff An integer overflow flaw was found in libtiff that exists in the tif_getimage.c file. This flaw allows an attacker to inject and execute arbitrary code when a user opens a crafted TIFF file. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability. 2021-03-09 not yet calculated CVE-2020-35523
MISC
MISC
MISC
DEBIAN libtiff — libtiff
  A heap-based buffer overflow flaw was found in libtiff in the handling of TIFF images in libtiff’s TIFF2PDF tool. A specially crafted TIFF file can lead to arbitrary code execution. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability. 2021-03-09 not yet calculated CVE-2020-35524
MISC
MISC
MISC
DEBIAN linux — linux_kernel An issue was discovered in the Linux kernel through 5.11.3. Certain iSCSI data structures do not have appropriate length constraints or checks, and can exceed the PAGE_SIZE value. An unprivileged user can send a Netlink message that is associated with iSCSI, and has a length up to the maximum length of a Netlink message. 2021-03-07 not yet calculated CVE-2021-27365
MISC
MISC
MISC
MLIST
MISC linux — linux_kernel
  An issue was discovered in the Linux kernel through 5.11.3. A kernel pointer leak can be used to determine the address of the iscsi_transport structure. When an iSCSI transport is registered with the iSCSI subsystem, the transport’s handle is available to unprivileged users via the sysfs file system, at /sys/class/iscsi_transport/$TRANSPORT_NAME/handle. When read, the show_transport_handle function (in drivers/scsi/scsi_transport_iscsi.c) is called, which leaks the handle. This handle is actually the pointer to an iscsi_transport struct in the kernel module’s global variables. 2021-03-07 not yet calculated CVE-2021-27363
MISC
MISC
MISC
MLIST linux — linux_kernel
  An out-of-bounds access flaw was found in the Linux kernel’s implementation of the eBPF code verifier in the way a user running the eBPF script calls dev_map_init_map or sock_map_alloc. This flaw allows a local user to crash the system or possibly escalate their privileges. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability. 2021-03-09 not yet calculated CVE-2021-20268
MISC
MISC linux — linux_kernel
  A flaw was found in the way memory resources were freed in the unix_stream_recvmsg function in the Linux kernel when a signal was pending. This flaw allows an unprivileged local user to crash the system by exhausting available memory. The highest threat from this vulnerability is to system availability. 2021-03-10 not yet calculated CVE-2021-20265
MISC
MISC linux — linux_kernel
  A race condition was found in the Linux kernels implementation of the floppy disk drive controller driver software. The impact of this issue is lessened by the fact that the default permissions on the floppy device (/dev/fd0) are restricted to root. If the permissions on the device have changed the impact changes greatly. In the default configuration root (or equivalent) permissions are required to attack this flaw. 2021-03-11 not yet calculated CVE-2021-20261
MISC
MISC linux — linux_kernel
  An issue was discovered in the Linux kernel through 5.11.3. drivers/scsi/scsi_transport_iscsi.c is adversely affected by the ability of an unprivileged user to craft Netlink messages. 2021-03-07 not yet calculated CVE-2021-27364
MISC
MISC
MLIST
MISC lucy — security_awareness_software
  LUCY Security Awareness Software through 4.7.x allows unauthenticated remote code execution because the Migration Tool (in the Support section) allows upload of .php files within a system.tar.gz file. The .php file becomes accessible with a public/system/static URI. 2021-03-11 not yet calculated CVE-2021-28132
MISC lxco — lxco
  An internal product security audit of LXCO, prior to version 1.2.2, discovered that optional passwords, if specified, for the Syslog and SMTP forwarders are written to an internal LXCO log file in clear text. Affected logs are captured in the First Failure Data Capture (FFDC) service log. The FFDC service log is only generated when requested by a privileged LXCO user and it is only accessible to the privileged LXCO user that requested the file. 2021-03-09 not yet calculated CVE-2020-8356
MISC magicconnect — client
  Untrusted search path vulnerability in Installer of MagicConnect Client program distributed before 2021 March 1 allows an attacker to gain privileges and via a Trojan horse DLL in an unspecified directory and to execute arbitrary code with the privilege of the user invoking the installer when a terminal is connected remotely using Remote desktop. 2021-03-12 not yet calculated CVE-2021-20674
MISC
MISC microsoft — azure Azure Sphere Unsigned Code Execution Vulnerability This CVE ID is unique from CVE-2021-27074. 2021-03-11 not yet calculated CVE-2021-27080
MISC microsoft — azure
  Azure Virtual Machine Information Disclosure Vulnerability 2021-03-11 not yet calculated CVE-2021-27075
MISC microsoft — azure
  Azure Sphere Unsigned Code Execution Vulnerability This CVE ID is unique from CVE-2021-27080. 2021-03-11 not yet calculated CVE-2021-27074
MISC microsoft — directx
  DirectX Elevation of Privilege Vulnerability 2021-03-11 not yet calculated CVE-2021-24095
MISC microsoft — excel Microsoft Excel Remote Code Execution Vulnerability This CVE ID is unique from CVE-2021-27053. 2021-03-11 not yet calculated CVE-2021-27054
MISC microsoft — excel
  Microsoft Excel Remote Code Execution Vulnerability This CVE ID is unique from CVE-2021-27054. 2021-03-11 not yet calculated CVE-2021-27053
MISC microsoft — internet_explorer Internet Explorer Remote Code Execution Vulnerability 2021-03-11 not yet calculated CVE-2021-27085
MISC microsoft — internet_explorer
  Internet Explorer Memory Corruption Vulnerability 2021-03-11 not yet calculated CVE-2021-26411
MISC microsoft — office Microsoft Office ClickToRun Remote Code Execution Vulnerability 2021-03-11 not yet calculated CVE-2021-27058
MISC microsoft — office
  Microsoft Office Remote Code Execution Vulnerability This CVE ID is unique from CVE-2021-24108, CVE-2021-27059. 2021-03-11 not yet calculated CVE-2021-27057
MISC microsoft — office
  Microsoft Office Remote Code Execution Vulnerability This CVE ID is unique from CVE-2021-24108, CVE-2021-27057. 2021-03-11 not yet calculated CVE-2021-27059
MISC microsoft — office
  Microsoft Office Remote Code Execution Vulnerability This CVE ID is unique from CVE-2021-27057, CVE-2021-27059. 2021-03-11 not yet calculated CVE-2021-24108
MISC microsoft — onetype_font
  OpenType Font Parsing Remote Code Execution Vulnerability 2021-03-11 not yet calculated CVE-2021-26876
MISC microsoft — power_bi_report_server
  Microsoft Power BI Information Disclosure Vulnerability 2021-03-11 not yet calculated CVE-2021-26859
MISC microsoft — powerpoint
  Microsoft PowerPoint Remote Code Execution Vulnerability 2021-03-11 not yet calculated CVE-2021-27056
MISC microsoft — sharepoint Microsoft SharePoint Server Remote Code Execution Vulnerability 2021-03-11 not yet calculated CVE-2021-27076
MISC
MISC microsoft — sharepoint
  Microsoft SharePoint Server Information Disclosure Vulnerability 2021-03-11 not yet calculated CVE-2021-27052
MISC microsoft — sharepoint
  Microsoft SharePoint Spoofing Vulnerability 2021-03-11 not yet calculated CVE-2021-24104
MISC microsoft — visio
  Microsoft Visio Security Feature Bypass Vulnerability 2021-03-11 not yet calculated CVE-2021-27055
MISC microsoft — visual_studio
  Visual Studio Code Remote Code Execution Vulnerability 2021-03-11 not yet calculated CVE-2021-27060
MISC microsoft — windows Windows DNS Server Remote Code Execution Vulnerability This CVE ID is unique from CVE-2021-26877, CVE-2021-26893, CVE-2021-26894, CVE-2021-26895. 2021-03-11 not yet calculated CVE-2021-26897
MISC microsoft — windows Windows Print Spooler Elevation of Privilege Vulnerability This CVE ID is unique from CVE-2021-26878. 2021-03-11 not yet calculated CVE-2021-1640
MISC microsoft — windows Windows Update Stack Setup Elevation of Privilege Vulnerability 2021-03-11 not yet calculated CVE-2021-1729
MISC microsoft — windows Windows DNS Server Denial of Service Vulnerability This CVE ID is unique from CVE-2021-26896. 2021-03-11 not yet calculated CVE-2021-27063
MISC microsoft — windows Windows 10 Update Assistant Elevation of Privilege Vulnerability 2021-03-11 not yet calculated CVE-2021-27070
MISC microsoft — windows Windows DNS Server Remote Code Execution Vulnerability This CVE ID is unique from CVE-2021-26877, CVE-2021-26893, CVE-2021-26894, CVE-2021-26897. 2021-03-11 not yet calculated CVE-2021-26895
MISC microsoft — windows Windows Event Tracing Elevation of Privilege Vulnerability This CVE ID is unique from CVE-2021-26872, CVE-2021-26901. 2021-03-11 not yet calculated CVE-2021-26898
MISC microsoft — windows Windows Graphics Component Elevation of Privilege Vulnerability 2021-03-11 not yet calculated CVE-2021-26868
MISC microsoft — windows Windows ActiveX Installer Service Information Disclosure Vulnerability 2021-03-11 not yet calculated CVE-2021-26869
MISC microsoft — windows Windows Event Tracing Elevation of Privilege Vulnerability This CVE ID is unique from CVE-2021-26898, CVE-2021-26901. 2021-03-11 not yet calculated CVE-2021-26872
MISC microsoft — windows
  Windows DNS Server Denial of Service Vulnerability This CVE ID is unique from CVE-2021-27063. 2021-03-11 not yet calculated CVE-2021-26896
MISC microsoft — windows
  Windows UPnP Device Host Elevation of Privilege Vulnerability 2021-03-11 not yet calculated CVE-2021-26899
MISC microsoft — windows
  Windows Event Tracing Information Disclosure Vulnerability 2021-03-11 not yet calculated CVE-2021-24107
MISC microsoft — windows
  Windows Win32k Elevation of Privilege Vulnerability This CVE ID is unique from CVE-2021-26863, CVE-2021-26875, CVE-2021-27077. 2021-03-11 not yet calculated CVE-2021-26900
MISC microsoft — windows
  Windows Event Tracing Elevation of Privilege Vulnerability This CVE ID is unique from CVE-2021-26872, CVE-2021-26898. 2021-03-11 not yet calculated CVE-2021-26901
MISC microsoft — windows
  Windows Projected File System Elevation of Privilege Vulnerability 2021-03-11 not yet calculated CVE-2021-26870
MISC microsoft — windows
  Windows Error Reporting Elevation of Privilege Vulnerability 2021-03-11 not yet calculated CVE-2021-24090
MISC microsoft — windows
  Windows WalletService Elevation of Privilege Vulnerability This CVE ID is unique from CVE-2021-26885. 2021-03-11 not yet calculated CVE-2021-26871
MISC microsoft — windows
  Windows User Profile Service Elevation of Privilege Vulnerability 2021-03-11 not yet calculated CVE-2021-26873
MISC microsoft — windows
  Windows Overlay Filter Elevation of Privilege Vulnerability 2021-03-11 not yet calculated CVE-2021-26874
MISC microsoft — windows
  Windows DNS Server Remote Code Execution Vulnerability This CVE ID is unique from CVE-2021-26893, CVE-2021-26894, CVE-2021-26895, CVE-2021-26897. 2021-03-11 not yet calculated CVE-2021-26877
MISC microsoft — windows
  Windows Win32k Elevation of Privilege Vulnerability This CVE ID is unique from CVE-2021-26863, CVE-2021-26900, CVE-2021-27077. 2021-03-11 not yet calculated CVE-2021-26875
MISC microsoft — windows
  Windows Admin Center Security Feature Bypass Vulnerability 2021-03-11 not yet calculated CVE-2021-27066
MISC microsoft — windows
  Windows Win32k Elevation of Privilege Vulnerability This CVE ID is unique from CVE-2021-26863, CVE-2021-26875, CVE-2021-26900. 2021-03-11 not yet calculated CVE-2021-27077
MISC microsoft — visual_studio Visual Studio Code ESLint Extension Remote Code Execution Vulnerability 2021-03-11 not yet calculated CVE-2021-27081
MISC microsoft — visual_studio Quantum Development Kit for Visual Studio Code Remote Code Execution Vulnerability 2021-03-11 not yet calculated CVE-2021-27082
MISC microsoft — visual_studio
  Visual Studio Code Java Extension Pack Remote Code Execution Vulnerability 2021-03-11 not yet calculated CVE-2021-27084
MISC microsoft — visual_studio
  Remote Development Extension for Visual Studio Code Remote Code Execution Vulnerability 2021-03-11 not yet calculated CVE-2021-27083
MISC msgpack5 — msgpack5
  msgpack5 is a msgpack v5 implementation for node.js and the browser. In msgpack5 before versions 3.6.1, 4.5.1, and 5.2.1 there is a “Prototype Poisoning” vulnerability. When msgpack5 decodes a map containing a key “__proto__”, it assigns the decoded value to __proto__. Object.prototype.__proto__ is an accessor property for the receiver’s prototype. If the value corresponding to the key __proto__ decodes to an object or null, msgpack5 sets the decoded object’s prototype to that value. An attacker who can submit crafted MessagePack data to a service can use this to produce values that appear to be of other types; may have unexpected prototype properties and methods (for example length, numeric properties, and push et al if __proto__’s value decodes to an Array); and/or may throw unexpected exceptions when used (for example if the __proto__ value decodes to a Map or Date). Other unexpected behavior might be produced for other types. There is no effect on the global prototype. This “prototype poisoning” is sort of a very limited inversion of a prototype pollution attack. Only the decoded value’s prototype is affected, and it can only be set to msgpack5 values (though if the victim makes use of custom codecs, anything could be a msgpack5 value). We have not found a way to escalate this to true prototype pollution (absent other bugs in the consumer’s code). This has been fixed in msgpack5 version 3.6.1, 4.5.1, and 5.2.1. See the referenced GitHub Security Advisory for an example and more details. 2021-03-12 not yet calculated CVE-2021-21368
MISC
MISC
MISC
MISC
CONFIRM
MISC netgear — jgs516pe/gs116ev2_devices Multiple integer overflow parameters were found in the web administration panel on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices. Most of the integer parameters sent through the web server can be abused to cause a denial of service attack. 2021-03-10 not yet calculated CVE-2020-35230
MISC netgear — jgs516pe/gs116ev2_devices The TFTP firmware update mechanism on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices does not properly implement firmware validations, allowing remote attackers to write arbitrary data to internal memory. 2021-03-10 not yet calculated CVE-2020-35232
MISC netgear — jgs516pe/gs116ev2_devices The CSRF protection mechanism implemented in the web administration panel on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices could be bypassed by omitting the CSRF token parameter in HTTP requests. 2021-03-10 not yet calculated CVE-2020-35223
MISC netgear — jgs516pe/gs116ev2_devices The NSDP protocol implementation on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices was not properly validating the length of string parameters sent in write requests, potentially allowing denial of service attacks. 2021-03-10 not yet calculated CVE-2020-35225
MISC netgear — jgs516pe/gs116ev2_devices NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices allow unauthenticated users to modify the switch DHCP configuration by sending the corresponding write request command. 2021-03-10 not yet calculated CVE-2020-35226
MISC netgear — jgs516pe/gs116ev2_devices The NSDP protocol implementation on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices was affected by an authentication issue that allows an attacker to bypass access controls and obtain full control of the device. 2021-03-10 not yet calculated CVE-2020-35231
MISC netgear — jgs516pe/gs116ev2_devices
  The authentication token required to execute NSDP write requests on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices is not properly invalidated and can be reused until a new token is generated, which allows attackers (with access to network traffic) to effectively gain administrative privileges. 2021-03-10 not yet calculated CVE-2020-35229
MISC netgear — jgs516pe/gs116ev2_devices
  A buffer overflow vulnerability in the access control section on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices (in the administration web panel) allows an attacker to inject IP addresses into the whitelist via the checkedList parameter to the delete command. 2021-03-10 not yet calculated CVE-2020-35227
MISC netgear — jgs516pe/gs116ev2_devices
  A buffer overflow vulnerability in the NSDP protocol authentication method on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices allows remote unauthenticated attackers to force a device reboot. 2021-03-10 not yet calculated CVE-2020-35224
MISC netgear — jgs516pe/gs116ev2_devices
  The NSDP protocol version implemented on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices allows unauthenticated remote attackers to obtain all the switch configuration parameters by sending the corresponding read requests. 2021-03-10 not yet calculated CVE-2020-35222
MISC netgear — jgs516pe/gs116ev2_devices
  The hashing algorithm implemented for NSDP password authentication on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices was found to be insecure, allowing attackers (with access to a network capture) to quickly generate multiple collisions to generate valid passwords, or infer some parts of the original. 2021-03-10 not yet calculated CVE-2020-35221
MISC netgear — jgs516pe/gs116ev2_devices
  A cross-site scripting (XSS) vulnerability in the administration web panel on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices allows remote attackers to inject arbitrary web script or HTML via the language parameter. 2021-03-10 not yet calculated CVE-2020-35228
MISC netgear — jgs516pe/gs116ev2_devices
  A TFTP server was found to be active by default on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices. It allows remote authenticated users to update the switch firmware. 2021-03-10 not yet calculated CVE-2020-35220
MISC netgear — jgs516pe/gs116ev2_devices
  The TFTP server fails to handle multiple connections on NETGEAR JGS516PE/GS116Ev2 v2.6.0.43 devices, and allows external attackers to force device reboots by sending concurrent connections, aka a denial of service attack. 2021-03-10 not yet calculated CVE-2020-35233
MISC netty — netty
  Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.60.Final there is a vulnerability that enables request smuggling. If a Content-Length header is present in the original HTTP/2 request, the field is not validated by `Http2MultiplexHandler` as it is propagated up. This is fine as long as the request is not proxied through as HTTP/1.1. If the request comes in as an HTTP/2 stream, gets converted into the HTTP/1.1 domain objects (`HttpRequest`, `HttpContent`, etc.) via `Http2StreamFrameToHttpObjectCodec `and then sent up to the child channel’s pipeline and proxied through a remote peer as HTTP/1.1 this may result in request smuggling. In a proxy case, users may assume the content-length is validated somehow, which is not the case. If the request is forwarded to a backend channel that is a HTTP/1.1 connection, the Content-Length now has meaning and needs to be checked. An attacker can smuggle requests inside the body as it gets downgraded from HTTP/2 to HTTP/1.1. For an example attack refer to the linked GitHub Advisory. Users are only affected if all of this is true: `HTTP2MultiplexCodec` or `Http2FrameCodec` is used, `Http2StreamFrameToHttpObjectCodec` is used to convert to HTTP/1.1 objects, and these HTTP/1.1 objects are forwarded to another remote peer. This has been patched in 4.1.60.Final As a workaround, the user can do the validation by themselves by implementing a custom `ChannelInboundHandler` that is put in the `ChannelPipeline` behind `Http2StreamFrameToHttpObjectCodec`. 2021-03-09 not yet calculated CVE-2021-21295
MISC
MISC
CONFIRM nginx — nginx
  An integer buffer overflow in the Nginx webserver of ExpressVPN Router version 1 allows remote attackers to obtain sensitive information when the server running as reverse proxy via specially crafted request. 2021-03-10 not yet calculated CVE-2020-29238
MISC
MISC
MISC october — october
  October is a free, open-source, self-hosted CMS platform based on the Laravel PHP Framework. In October before version 1.1.2, when running on poorly configured servers (i.e. the server routes any request, regardless of the HOST header to an October CMS instance) the potential exists for Host Header Poisoning attacks to succeed. This has been addressed in version 1.1.2 by adding a feature to allow a set of trusted hosts to be specified in the application. As a workaround one may set the configuration setting cms.linkPolicy to force. 2021-03-10 not yet calculated CVE-2021-21265
MISC
MISC
CONFIRM open5gs — open5gs
  A request-validation issue was discovered in Open5GS 2.1.3 through 2.2.0. The WebUI component allows an unauthenticated user to use a crafted HTTP API request to create, read, update, or delete entries in the subscriber database. For example, new administrative users can be added. The issue occurs because Express is not set up to require authentication. 2021-03-10 not yet calculated CVE-2021-28122
MISC
MISC
MISC pjsip — pjsip
  PJSIP is a free and open source multimedia communication library written in C language implementing standard based protocols such as SIP, SDP, RTP, STUN, TURN, and ICE. In PJSIP version 2.10 and earlier, after an initial INVITE has been sent, when two 183 responses are received, with the first one causing negotiation failure, a crash will occur. This results in a denial of service. 2021-03-10 not yet calculated CVE-2021-21375
MISC
CONFIRM pjsip — pjsip
  PJSIP is a free and open source multimedia communication library written in C language implementing standard based protocols such as SIP, SDP, RTP, STUN, TURN, and ICE. In version 2.10 and earlier, PJSIP transport can be reused if they have the same IP address + port + protocol. However, this is insufficient for secure transport since it lacks remote hostname authentication. Suppose we have created a TLS connection to `sip.foo.com`, which has an IP address `100.1.1.1`. If we want to create a TLS connection to another hostname, say `sip.bar.com`, which has the same IP address, then it will reuse that existing connection, even though `100.1.1.1` does not have certificate to authenticate as `sip.bar.com`. The vulnerability allows for an insecure interaction without user awareness. It affects users who need access to connections to different destinations that translate to the same address, and allows man-in-the-middle attack if attacker can route a connection to another destination such as in the case of DNS spoofing. 2021-03-10 not yet calculated CVE-2020-15260
MISC
MISC
CONFIRM powerlogic — multiple_products
  A CWE-119:Improper restriction of operations within the bounds of a memory buffer vulnerability exists in PowerLogic ION8650, ION8800, ION7650, ION7700/73xx, and ION83xx/84xx/85xx/8600 (see security notifcation for affected versions), which could cause the meter to reboot. 2021-03-11 not yet calculated CVE-2021-22713
MISC powerlogic — multiple_products
  A CWE-119:Improper restriction of operations within the bounds of a memory buffer vulnerability exists in PowerLogic ION7400, PM8000 and ION9000 (All versions prior to V3.0.0), which could cause the meter to reboot or allow for remote code execution. 2021-03-11 not yet calculated CVE-2021-22714
MISC printf — printf
  The package printf before 0.6.1 are vulnerable to Regular Expression Denial of Service (ReDoS) via the regex string /\%(?:\(([\w_.]+)\)|([1-9]\d*)\$)?([0 +\-\]*)(\*|\d+)?(\.)?(\*|\d+)?[hlL]?([\%bscdeEfFgGioOuxX])/g in lib/printf.js. The vulnerable regular expression has cubic worst-case time complexity. 2021-03-12 not yet calculated CVE-2021-23354
CONFIRM
CONFIRM
CONFIRM pupnp — pupnp
  A stack overflow in pupnp 1.16.1 can cause the denial of service through the Parser_parseDocument() function. ixmlNode_free() will release a child node recursively, which will consume stack space and lead to a crash. 2021-03-12 not yet calculated CVE-2021-28302
MISC qemu — eepro100_i8255x_devices
  A stack overflow via an infinite recursion vulnerability was found in the eepro100 i8255x device emulator of QEMU. This issue occurs while processing controller commands due to a DMA reentry issue. This flaw allows a guest user or process to consume CPU cycles or crash the QEMU process on the host, resulting in a denial of service. The highest threat from this vulnerability is to system availability. 2021-03-09 not yet calculated CVE-2021-20255
MISC
MISC
MISC qemu — qemu
  A flaw was found in the virtio-fs shared file system daemon (virtiofsd) of QEMU. The new ‘xattrmap’ option may cause the ‘security.capability’ xattr in the guest to not drop on file write, potentially leading to a modified, privileged executable in the guest. In rare circumstances, this flaw could be used by a malicious user to elevate their privileges within the guest. 2021-03-09 not yet calculated CVE-2021-20263
MISC
MISC quadbase — espressreports
  An issue was discovered in Quadbase EspressReports ES 7 Update 9. An unauthenticated attacker can create a malicious HTML file that houses a POST request made to the DashboardBuilder within the target web application. This request will utilise the target admin session and perform the authenticated request (to change the Dashboard name) as if the victim had done so themselves, aka CSRF. 2021-03-11 not yet calculated CVE-2020-24983
MISC quadbase — espressreports
  An issue was discovered in Quadbase EspressReports ES 7 Update 9. It allows CSRF, whereby an attacker may be able to trick an authenticated admin level user into uploading malicious files to the web server. 2021-03-11 not yet calculated CVE-2020-24984
MISC rabbitmq — rabbitmq
  JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via crafted StreamMessage data. 2021-03-12 not yet calculated CVE-2020-36282
MISC
MISC
MISC
MISC redhat — keycloak A flaw was found in Keycloak 12.0.0 where re-authentication does not occur while updating the password. This flaw allows an attacker to take over an account if they can obtain temporary, physical access to a user’s browser. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability. 2021-03-09 not yet calculated CVE-2021-20262
MISC redhat — keycloak
  A flaw was found in keycloak in versions prior to 13.0.0. The client registration endpoint allows fetching information about PUBLIC clients (like client secret) without authentication which could be an issue if the same PUBLIC client changed to CONFIDENTIAL later. The highest threat from this vulnerability is to data confidentiality. 2021-03-08 not yet calculated CVE-2020-27838
MISC rust — rust An issue was discovered in the fltk crate before 0.15.3 for Rust. There is an out-of bounds read because the pixmap constructor lacks pixmap input validation. 2021-03-12 not yet calculated CVE-2021-28308
MISC rust — rust An issue was discovered in the fltk crate before 0.15.3 for Rust. There is a NULL pointer dereference during attempted use of a multi label type if the image is nonexistent. 2021-03-12 not yet calculated CVE-2021-28306
MISC rust — rust
  An issue was discovered in the fltk crate before 0.15.3 for Rust. There is a NULL pointer dereference during attempted use of a non-raster image for a window icon. 2021-03-12 not yet calculated CVE-2021-28307
MISC rust — rust
  An issue was discovered in the diesel crate before 1.4.6 for Rust. There is a use-after-free in the SQLite backend because the semantics of sqlite3_column_name are not followed. 2021-03-12 not yet calculated CVE-2021-28305
MISC sap — 3d_visual_enterprise_viewer
  When a user opens manipulated Graphics Interchange Format (.GIF) format files received from untrusted sources in SAP 3D Visual Enterprise Viewer version 9, the application crashes and becomes temporarily unavailable to the user until restart of the application. 2021-03-09 not yet calculated CVE-2021-21493
MISC
MISC sap — enterprise_financial_services
  SAP Enterprise Financial Services versions, 101, 102, 103, 104, 105, 600, 603, 604, 605, 606, 616, 617, 618, 800, does not perform necessary authorization checks for an authenticated user, resulting in escalation of privileges. 2021-03-09 not yet calculated CVE-2021-21486
MISC
MISC sap — hana_database
  LDAP authentication in SAP HANA Database version 2.0 can be bypassed if the attached LDAP directory server is configured to enable unauthenticated bind. 2021-03-09 not yet calculated CVE-2021-21484
MISC
MISC sap — knowledge_management
  Knowledge Management versions 7.01, 7.02, 7.30, 7.31, 7.40, 7.50 allows a remote attacker with basic privileges to deserialize user-controlled data without verification, leading to insecure deserialization which triggers the attacker’s code, therefore impacting Availability. 2021-03-09 not yet calculated CVE-2021-21488
MISC
MISC sap — mii
  SAP MII allows users to create dashboards and save them as JSP through the SSCE (Self Service Composition Environment). An attacker can intercept a request to the server, inject malicious JSP code in the request and forward to server. When this dashboard is opened by Users having at least SAP_XMII_Developer role, malicious content in the dashboard gets executed, leading to remote code execution in the server, which allows privilege escalation. The malicious JSP code can contain certain OS commands, through which an attacker can read sensitive files in the server, modify files or even delete contents in the server thus compromising the confidentiality, integrity and availability of the server hosting the SAP MII application. 2021-03-09 not yet calculated CVE-2021-21480
MISC
MISC sap — netweaver
  The MigrationService, which is part of SAP NetWeaver versions 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50, does not perform an authorization check. This might allow an unauthorized attacker to access configuration objects, including such that grant administrative privileges. This could result in complete compromise of system confidentiality, integrity, and availability. 2021-03-09 not yet calculated CVE-2021-21481
MISC
MISC sap — netweaver_application_server
  SAP Netweaver Application Server Java (Applications based on WebDynpro Java) versions 7.00, 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50, allow an attacker to redirect users to a malicious site due to Reverse Tabnabbing vulnerabilities. 2021-03-10 not yet calculated CVE-2021-21491
MISC
MISC sap — payment_engine
  SAP Payment Engine version 500, does not perform necessary authorization checks for an authenticated user, resulting in escalation of privileges. 2021-03-09 not yet calculated CVE-2021-21487
MISC
MISC schneider_electric — igss A CWE-119:Improper Restriction of Operations within the Bounds of a Memory Buffer vulnerability exists in Interactive Graphical SCADA System (IGSS) Definition (Def.exe) V15.0.0.21041 and prior, which could result in arbitrary read or write conditions when malicious CGF (Configuration Group File) file is imported to IGSS Definition due to missing validation of input data. 2021-03-11 not yet calculated CVE-2021-22711
MISC
MISC schneider_electric — igss
  A CWE-119:Improper Restriction of Operations within the Bounds of a Memory Buffer vulnerability exists in Interactive Graphical SCADA System (IGSS) Definition (Def.exe) V15.0.0.21041 and prior, which could result in loss of data or remote code execution when malicious CGF (Configuration Group File) file is imported to IGSS Definition. 2021-03-11 not yet calculated CVE-2021-22709
MISC
MISC schneider_electric — igss
  A CWE-119:Improper Restriction of Operations within the Bounds of a Memory Buffer vulnerability exists in Interactive Graphical SCADA System (IGSS) Definition (Def.exe) V15.0.0.21041 and prior, which could cause remote code execution when malicious CGF (Configuration Group File) file is imported to IGSS Definition. 2021-03-11 not yet calculated CVE-2021-22710
MISC
MISC schneider_electric — igss
  A CWE-119:Improper Restriction of Operations within the Bounds of a Memory Buffer vulnerability exists in Interactive Graphical SCADA System (IGSS) Definition (Def.exe) V15.0.0.21041 and prior, which could result in arbitrary read or write conditions when malicious CGF (Configuration Group File) file is imported to IGSS Definition due to an unchecked pointer address. 2021-03-11 not yet calculated CVE-2021-22712
MISC
MISC simatic — mv400
  In SIMATIC MV400 family versions prior to v7.0.6, the ISN generator is initialized with a constant value and has constant increments. An attacker could predict and hijack TCP sessions. 2021-03-10 not yet calculated CVE-2020-27632
CONFIRM sonicwall — sma100 A post-authenticated vulnerability in SonicWall SMA100 allows an attacker to export the configuration file to the specified email address. This vulnerability impacts SMA100 version 10.2.0.5 and earlier. 2021-03-13 not yet calculated CVE-2021-20018
CONFIRM sonicwall — sma100
  A post-authenticated command injection vulnerability in SonicWall SMA100 allows an authenticated attacker to execute OS commands as a ‘nobody’ user. This vulnerability impacts SMA100 version 10.2.0.5 and earlier. 2021-03-13 not yet calculated CVE-2021-20017
CONFIRM spdk — spdk
  An issue was discovered in Storage Performance Development Kit (SPDK) before 20.01.01. If a PDU is sent to the iSCSI target with a zero length (but data is expected), the iSCSI target can crash with a NULL pointer dereference. 2021-03-13 not yet calculated CVE-2021-28361
MISC ssri — ssri
  ssri 5.2.2-8.0.0, fixed in 8.0.1, processes SRIs using a regular expression which is vulnerable to a denial of service. Malicious SRIs could take an extremely long time to process, leading to denial of service. This issue only affects consumers using the strict option. 2021-03-12 not yet calculated CVE-2021-27290
MISC
MISC swagger-codegen — swagger-codegen
  swagger-codegen is an open-source project which contains a template-driven engine to generate documentation, API clients and server stubs in different languages by parsing your OpenAPI / Swagger definition. In swagger-codegen before version 2.4.19, on Unix like systems, the system’s temporary directory is shared between all users on that system. A collocated user can observe the process of creating a temporary sub directory in the shared temporary directory and race to complete the creation of the temporary subdirectory. This vulnerability is local privilege escalation because the contents of the `outputFolder` can be appended to by an attacker. As such, code written to this directory, when executed can be attacker controlled. For more details refer to the referenced GitHub Security Advisory. This vulnerability is fixed in version 2.4.19. Note this is a distinct vulnerability from CVE-2021-21364. 2021-03-11 not yet calculated CVE-2021-21363
MISC
CONFIRM swagger-codegen — swagger-codegen
  swagger-codegen is an open-source project which contains a template-driven engine to generate documentation, API clients and server stubs in different languages by parsing your OpenAPI / Swagger definition. In swagger-codegen before version 2.4.19, on Unix-Like systems, the system temporary directory is shared between all local users. When files/directories are created, the default `umask` settings for the process are respected. As a result, by default, most processes/apis will create files/directories with the permissions `-rw-r–r–` and `drwxr-xr-x` respectively, unless an API that explicitly sets safe file permissions is used. Because this vulnerability impacts generated code, the generated code will remain vulnerable until fixed manually! This vulnerability is fixed in version 2.4.19. Note this is a distinct vulnerability from CVE-2021-21363. 2021-03-11 not yet calculated CVE-2021-21364
MISC
CONFIRM switchboard — bluetooth_plug
  Switchboard Bluetooth Plug for elementary OS from version 2.3.0 and before version version 2.3.5 has an incorrect authorization vulnerability. When the Bluetooth plug is running (in discoverable mode), Bluetooth service requests and pairing requests are automatically accepted, allowing physically proximate attackers to pair with a device running an affected version of switchboard-plug-bluetooth without the active consent of the user. By default, elementary OS doesn’t expose any services via Bluetooth that allow information to be extracted by paired Bluetooth devices. However, if such services (i.e. contact list sharing software) have been installed, it’s possible that attackers have been able to extract data from such services without authorization. If no such services have been installed, attackers are only able to pair with a device running an affected version without authorization and then play audio out of the device or possibly present a HID device (keyboard, mouse, etc…) to control the device. As such, users should check the list of trusted/paired devices and remove any that are not 100% confirmed to be genuine. This is fixed in version 2.3.5. To reduce the likelihood of this vulnerability on an unpatched version, only open the Bluetooth plug for short intervals when absolutely necessary and preferably not in crowded public areas. To mitigate the risk entirely with unpatched versions, do not open the Bluetooth plug within switchboard at all, and use a different method for pairing devices if necessary (e.g. `bluetoothctl` CLI). 2021-03-12 not yet calculated CVE-2021-21367
MISC
MISC
CONFIRM synology — diskstation_manager
  Out-of-bounds Read vulnerability in iscsi_snapshot_comm_core in Synology DiskStation Manager (DSM) before 6.2.3-25426-3 allows remote attackers to execute arbitrary code via crafted web requests. 2021-03-12 not yet calculated CVE-2021-27647
CONFIRM synology — diskstation_manager
  Use After Free vulnerability in iscsi_snapshot_comm_core in Synology DiskStation Manager (DSM) before 6.2.3-25426-3 allows remote attackers to execute arbitrary code via crafted web requests. 2021-03-12 not yet calculated CVE-2021-27646
CONFIRM synology — diskstation_manager
  Race Condition within a Thread vulnerability in iscsi_snapshot_comm_core in Synology DiskStation Manager (DSM) before 6.2.3-25426-3 allows remote attackers to execute arbitrary code via crafted web requests. 2021-03-12 not yet calculated CVE-2021-26569
CONFIRM telerik — telerik
  ** DISPUTED ** An issue was discovered in Progress Telerik UI for ASP.NET AJAX 2021.1.224. It allows unauthorized access to MicrosoftAjax.js through the Telerik.Web.UI.WebResource.axd file. This may allow the attacker to gain unauthorized access to the server and execute code. To exploit, one must use the parameter _TSM_HiddenField_ and inject a command at the end of the URI. NOTE: the vendor states that this is not a vulnerability. The request’s output does not indicate that a “true” command was executed on the server, and the request’s output does not leak any private source code or data from the server. 2021-03-11 not yet calculated CVE-2021-28141
MISC
MISC tenable — jira_cloud
  Tenable for Jira Cloud is an open source project designed to pull Tenable.io vulnerability data, then generate Jira Tasks and sub-tasks based on the vulnerabilities’ current state. It published in pypi as “tenable-jira-cloud”. In tenable-jira-cloud before version 1.1.21, it is possible to run arbitrary commands through the yaml.load() method. This could allow an attacker with local access to the host to run arbitrary code by running the application with a specially crafted YAML configuration file. This is fixed in version 1.1.21 by using yaml.safe_load() instead of yaml.load(). 2021-03-10 not yet calculated CVE-2021-21371
MISC
CONFIRM
MISC
MISC tibco — multiple_products
  The Spotfire client component of TIBCO Software Inc.’s TIBCO Spotfire Analyst, TIBCO Spotfire Analytics Platform for AWS Marketplace, TIBCO Spotfire Desktop, and TIBCO Spotfire Server contains a vulnerability that theoretically allows a low privileged attacker with network access to execute a stored Cross Site Scripting (XSS) attack on the affected system. A successful attack using this vulnerability requires human interaction from a person other than the attacker. Affected releases are TIBCO Software Inc.’s TIBCO Spotfire Analyst: versions 10.3.3 and below, versions 10.10.0, 10.10.1, and 10.10.2, versions 10.7.0, 10.8.0, 10.9.0, 11.0.0, and 11.1.0, TIBCO Spotfire Analytics Platform for AWS Marketplace: versions 11.1.0 and below, TIBCO Spotfire Desktop: versions 10.3.3 and below, versions 10.10.0, 10.10.1, and 10.10.2, versions 10.7.0, 10.8.0, 10.9.0, 11.0.0, and 11.1.0, and TIBCO Spotfire Server: versions 10.3.11 and below, versions 10.10.0, 10.10.1, 10.10.2, and 10.10.3, versions 10.7.0, 10.8.0, 10.8.1, 10.9.0, 11.0.0, and 11.1.0. 2021-03-09 not yet calculated CVE-2021-23273
CONFIRM
CONFIRM tiny — tiny_rss
  The auth_internal plugin in Tiny Tiny RSS (aka tt-rss) before 2021-03-12 allows an attacker to log in via the OTP code without a valid password. NOTE: this issue only affected the git master branch for a short time. However, all end users are explicitly directed to use the git master branch in production. Semantic version numbers such as 21.03 appear to exist, but are automatically generated from the year and month. They are not releases. 2021-03-13 not yet calculated CVE-2021-28373
MISC
MISC twinkle_tray — twinkle_tray
  Twinkle Tray (aka twinkle-tray) through 1.13.3 allows remote command execution. A remote attacker may send a crafted IPC message to the exposed vulnerable ipcRenderer IPC interface, which invokes the dangerous openExternal API. 2021-03-09 not yet calculated CVE-2021-28119
MISC vxworks — vxworks
  ** UNSUPPORTED WHEN ASSIGNED ** A DNS client stack-based buffer overflow in ipdnsc_decode_name() affects Wind River VxWorks 6.5 through 7. NOTE: This vulnerability only affects products that are no longer supported by the maintainer. 2021-03-11 not yet calculated CVE-2016-20009
MISC web_based_quiz_system — web_based_quiz_system
  Web Based Quiz System 1.0 is affected by cross-site scripting (XSS) in register.php through the name parameter. 2021-03-10 not yet calculated CVE-2021-28007
MISC weseek — growi Improper access control vulnerability in GROWI versions v4.2.2 and earlier allows a remote unauthenticated attacker to read the user’s personal information and/or server’s internal information via unspecified vectors. 2021-03-10 not yet calculated CVE-2021-20670
MISC
MISC weseek — growi
  Invalid file validation on the upload feature in GROWI versions v4.2.2 allows a remote attacker with administrative privilege to overwrite the files on the server, which may lead to arbitrary code execution. 2021-03-10 not yet calculated CVE-2021-20671
MISC
MISC weseek — growi
  Stored cross-site scripting vulnerability due to inadequate CSP (Content Security Policy) configuration in GROWI versions v4.2.2 and earlier allows remote authenticated attackers to inject an arbitrary script via a specially crafted content. 2021-03-10 not yet calculated CVE-2021-20667
MISC
MISC weseek — growi
  Path traversal vulnerability in GROWI versions v4.2.2 and earlier allows an attacker with administrator rights to read an arbitrary path via a specially crafted URL. 2021-03-10 not yet calculated CVE-2021-20668
MISC
MISC weseek — growi
  Path traversal vulnerability in GROWI versions v4.2.2 and earlier allows an attacker with administrator rights to read and/or delete an arbitrary path via a specially crafted URL. 2021-03-10 not yet calculated CVE-2021-20669
MISC
MISC weseek — growi
  Stored cross-site scripting vulnerability in Admin Page of GROWI (v4.2 Series) versions from v4.2.0 to v4.2.7 allows remote authenticated attackers to inject an arbitrary script via unspecified vectors. 2021-03-10 not yet calculated CVE-2021-20673
MISC
MISC weseek — growi
  Reflected cross-site scripting vulnerability due to insufficient verification of URL query parameters in GROWI (v4.2 Series) versions from v4.2.0 to v4.2.7 allows remote attackers to inject an arbitrary script via unspecified vectors. 2021-03-10 not yet calculated CVE-2021-20672
MISC
MISC western_digital — my_cloud_os_5_devices
  Western Digital My Cloud OS 5 devices before 5.10.122 mishandle Symbolic Link Following on SMB and AFP shares. This can lead to code execution and information disclosure (by reading local files). 2021-03-10 not yet calculated CVE-2021-3310
MISC
MISC wordpress — wordpress
  The food-and-drink-menu plugin through 2.2.0 for WordPress allows remote attackers to execute arbitrary code because of an unserialize operation on the fdm_cart cookie in load_cart_from_cookie in includes/class-cart-manager.php. 2021-03-11 not yet calculated CVE-2020-29045
MISC
MISC xmldom — xmldom
  xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. xmldom versions 0.4.0 and older do not correctly preserve system identifiers, FPIs or namespaces when repeatedly parsing and serializing maliciously crafted documents. This may lead to unexpected syntactic changes during XML processing in some downstream applications. This is fixed in version 0.5.0. As a workaround downstream applications can validate the input and reject the maliciously crafted documents. 2021-03-12 not yet calculated CVE-2021-21366
MISC
MISC
CONFIRM
MISC xwiki_platform — xwiki_platform
  XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions of XWiki Platform, the `{{wikimacrocontent}}` executes the content with the rights of the wiki macro author instead of the caller of that wiki macro. This makes possible to inject scripts through it and they will be executed with the rights of the wiki macro (very often a user which has Programming rights). Fortunately, no such macro exists by default in XWiki Standard but one could have been created or installed with an extension. This vulnerability has been patched in versions XWiki 12.6.3, 11.10.11 and 12.8-rc-1. There is no easy workaround other than disabling the affected macros. Inserting content in a safe way or knowing what is the user who called the wiki macro is not easy. 2021-03-12 not yet calculated CVE-2021-21379
CONFIRM
MISC zoho_manageengine — servicedesk_plus
  Zoho ManageEngine ServiceDesk Plus before 11134 allows an Authentication Bypass (only during SAML login). 2021-03-13 not yet calculated CVE-2020-35682
MISC zte — multiple_products
  Some ZTE products have an input verification vulnerability in the diagnostic function interface. Due to insufficient verification of some parameters input by users, an attacker with high privileges can cause process exception by repeatedly inputting illegal parameters. This affects:<ZXONE 9700 , ZXONE 8700, ZXONE 19700><V1.40.021.021CP049, V1.0P02B219_@NCPM-RELEASE_2.40R1-20200914.set> 2021-03-12 not yet calculated CVE-2021-21726
MISC

Source

Leave a Reply

Your email address will not be published. Required fields are marked *

Next Post

Microsoft-exchange Machine zero-day assaults: Harmful software found on two, 300 devices in the UK

Mon Mar 15 , 2021
Any companies which have however to utilize the particular vital improvements to secure zero-day vulnerabilities in Microsoft-exchange Server are now being urged to do this instantly to avoid precisely described as an ‘increasing range’ of hacking groups attempting to exploit unpatched networks. A warn through the Britian’s Nationwide Internet Protection […]